icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.mzcsc.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

东京28 www.904298.com-彩票代理能赚钱吗| www.cai4242.com内蒙古快三343| www.810126.com-鸿运彩票号码注册| www.942507.com-深圳体彩兑奖中心| 福彩www.86267i.com| www.mi80.com-一分彩计划软件下载| www.37uo.com-有七星彩平台吗| www.3669.win-彩票大师apk| www.01217.com-足球彩票竞猜技巧| www.72684.com-即时开彩香港版| www.051181.com-彩票合买微-| www.024329.com-福彩3d迷图-| www.140324.com-华宇彩票平台怎么样| www.yu96.com-用手机买彩票| www.85rk.com-中彩票后领奖流程| www.5173.me-足彩对阵麦-| www.17684.com-505彩票靠谱吗| www.71160.com-福利彩票视频彩票| www.100797.com-乐彩网静坛版| www.182147.com-湖北福利彩票快3| www.258495.com-竞彩分析网站| www.333565.com-外卖送彩票违法吗| www.451898.com-时时分分彩怎么玩| www.573521.com-淘彩票是什么| www.664303.com-福彩三地太谜语| www.743598.com-购彩111骗局| www.822326.com-福利彩票36选7| www.201002.com-七星彩图规-| www.787455.com-所新浪竞彩比分| www.888450.com-大发快三买数字技巧| www.962264.com-凤凰彩票正规么| www.cp340.cc-武汉快三开奖结累| www.pw06.com-长城彩票购彩大厅| www.23si.com-凤彩网怎么打不开| www.799.me-数字彩票频道新浪网| www.6169.xyz-盈众彩票官网| www.24841.com-即开型彩票猫腻| www.73312.cc-818彩票-| www.081957.com-彩经网彩票预测| www.158708.com-体彩网黑龙江| www.267512.com-彩票10选3技巧| www.371465.com-577彩票apk-| www.484950.com-怛大彩票-| www.566560.com-二四六好彩报刊大全| www.650004.com-博彩业巨头-| www.775395.com-彩票有多少位数| www.865330.com-福彩最大遗漏| www.929646.com-七星彩复式奖金计算| www.983361.com-彩31彩票领导官网| www.cp9295.com-河北快三一定牛走势| www.pr17.com-福彩3d大本营| www.08nl.com-合买彩票中奖案例| www.84ks.com-彩票后二倍数怎么算| www.2535.cn-玩彩票的方法与技巧| www.8613.top-49彩票手机安卓版| www.63906.com-足彩单关赚钱技巧| www.028201.com-奔驰彩票app安卓| www.111136.com-体育彩票十分钟即开| www.153933.com-足彩推荐论坛哪个好| www.290244.com-彩票收藏精品| www.391005.com-购福彩双色球选号| www.518560.com-江西福彩主任| www.kf44.com-手机购彩主页| www.20uf.com-彩票2019034| www.1961.com-成都体彩店申请条件| www.8360.vip-七星彩软件破解版| www.35276.com-如何追回黑彩输的钱| www.85368.cc-3个数的彩票| www.093416.com-高频彩为什么合法| www.205125.com-喜乐彩-| www.306019.com-彩票下载苹果| www.385232.com-福彩孤舟预测| www.nf77.com-c038彩票网址| www.6gt.com-彩票大乐透奖金分配| www.130524.com-汇彩网大发快三| www.226990.com-福建省福彩快三玩法| www.336063.com-网络彩票不给提现| www.097065.com-福彩公益报谜语| www.218989.com-博众时时彩软件下载| www.302191.com-七星彩和质走势图| www.659243.com-湖北省体育彩票网| www.ag04.com-123彩票app-| www.677664.com-今晚足彩推荐| www.818208.com-足彩当前期对阵预测| www.279262.com-手机彩票群骗局揭秘| www.500099.com-078彩票可靠吗| www.608255.com-3d新彩吧字迷总汇| www.693861.com-体彩双色球机选号码| www.893176.com-万能彩票过滤器| www.222488.com-彩票平台注送彩金| www.369588.cc-爱购彩票软件安全吗| www.520606.com-快三限号销售| www.45bz.com-排三杀号众彩网| www.2523.cn-1分钟快彩-| www.9812.org-广东三快三是私人彩| www.66535.cc-宁夏福彩中奖故事| www.021304.com-彩票怎么玩儿| www.095581.com-爱彩乐黑网-| www.169782.com-韩国快三走势图| www.247144.com-广东体彩网官网| www.323899.com-七乐彩开奖各省中奖| www.395164.com-彩虹正版易支付源码| www.870242.com-三分钟时彩软件| www.278697.com-分分彩精准杀一码| www.484806.cc-福建体育彩票领奖| www.585925.com-28彩票线路检测| www.697927.com-彩吧图库第三版| www.785127.com-七星彩数字计算规律| www.870972.com-南宁福彩兑奖中心| www.02200.com-巨龙彩票平台怎么样| www.65692.com-快三和值追号技巧| www.043258.com-9亿彩票用户注册| www.133752.com-彩八在哪里下载软件| www.213556.com-网络彩票-| www.288221.com-彩票用语-| www.362266.com-彩虹写个比喻句| www.19546.cc-好易彩票-| www.033341.com-彩站宝怎么扫码出票| www.365168.cc-6合宝典彩图下载| www.702768.com-彩店宝下架了吗| www.804426.com-福彩双色球号码范围| www.ka95.com-彩票三个红号有奖不| www.25cs.com-公益华彩-| www.2389.cc-天天彩票在线充值| www.8414.cm-爱彩乐旧版走势图| www.66228.com-五星彩票真实性| www.108625.com-玩彩票上瘾怎么办| www.10225.com-吉祥彩票官方彩票网| www.006728.com-彩界联盟app下载| www.123060.com-快三规律-| www.200966.com-杳看开七星彩| www.267518.com-彩票打票员教程视频| www.473048.com-腾讯分分彩互刷| www.563865.com-体彩23期寻马图| www.649363.com-166彩票网安全吗| www.771274.com-彩虹六号战队排名| www.834293.com-好彩蓝莓爆怎么买| www.886287.com-古风女背影彩铅| www.951615.com-澳客彩票网官方端口| www.991001.com-乐赢彩票登录| www.iv2.com-uu快3手机购彩| www.pr86.com-go彩平台-| www.810775.com-七彩乐历史开奖| www.881553.com-海南南国彩票论坛| www.cp9398.com-手机彩票软件排名| www.nl00.cc-足彩资讯-| www.s04.org-快乐双彩开奖| www.28831.cc-福星彩开奖记录| www.84637.com-福彩套利靠谱吗| www.496707.com-小米手机隐藏彩蛋| www.601954.com-梦见中彩票买车| www.678663.com-趣彩屏-| www.767000.com-k彩游戏app-| www.905130.com-江西福彩快三直播| www.971634.com-江苏快三开奖记录| 七彩www.53900e.com| www.ca32.com-武汉快三的走势图| www.098012.com-彩票种类大全| www.36607.com-3d澳门彩报图四4| www.819195.com-彩票平刷思路| www.896516.com-火星彩票-| www.8124.com-彩票3d几点停售| www.47092.com-彩礼钱是给女方父母| www.013177.com-海南彩票天涯论坛|